Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/lightgallery
  4. ›
  5. CVE-2025-48447

CVE-2025-48447: Drupal Lightgallery Cross-site Scripting vulnerability

June 11, 2025

Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Drupal Lightgallery allows Cross-Site Scripting (XSS). This issue affects Lightgallery: from 0.0.0 before 1.6.0.

References

  • github.com/advisories/GHSA-w5px-5878-m9x4
  • nvd.nist.gov/vuln/detail/CVE-2025-48447
  • www.drupal.org/sa-contrib-2025-069

Code Behaviors & Features

Detect and mitigate CVE-2025-48447 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.0

Fixed versions

  • 1.6.0

Solution

Upgrade to version 1.6.0 or above.

Impact 7.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/lightgallery/CVE-2025-48447.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.