Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/google_tag
  4. ›
  5. CVE-2025-31682

CVE-2025-31682: Drupal Google Tag Cross-Site Scripting (XSS) vulnerability

April 1, 2025 (updated April 29, 2025)

Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS). This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

References

  • git.drupalcode.org/project/google_tag
  • github.com/advisories/GHSA-36vv-q5jv-94cj
  • nvd.nist.gov/vuln/detail/CVE-2025-31682
  • www.drupal.org/sa-contrib-2025-011

Code Behaviors & Features

Detect and mitigate CVE-2025-31682 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.0, all versions starting from 2.0.0 before 2.0.8

Fixed versions

  • 1.8.0
  • 2.0.8

Solution

Upgrade to versions 1.8.0, 2.0.8 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/google_tag/CVE-2025-31682.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.