Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. SA-CORE-2018-003

SA-CORE-2018-003: XSS Vulnerability

March 18, 2018

CKEditor, a third-party JavaScript library included in Drupal core, is affected by a cross-site scripting (XSS) vulnerability. It’s possible to execute XSS inside CKEditor when using the image2 plugin.

References

  • www.drupal.org/sa-core-2018-003

Code Behaviors & Features

Detect and mitigate SA-CORE-2018-003 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.4.7, all versions starting from 8.5.0-alpha0 before 8.5.2

Fixed versions

  • 8.4.7
  • 8.5.2

Solution

Upgrade to versions 8.4.7, 8.5.2 or above.

Source file

packagist/drupal/core/SA-CORE-2018-003.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:27 +0000.