Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2022-29248

CVE-2022-29248: Exposure of Sensitive Information to an Unauthorized Actor

May 25, 2022 (updated July 21, 2023)

Drupal uses the third-party Guzzle library for handling HTTP requests and responses to external services. Guzzle has released a security update which does not affect Drupal core, but may affect some contributed projects or custom code on Drupal sites.

References

  • github.com/guzzle/guzzle/commit/74a8602c6faec9ef74b7a9391ac82c5e65b1cdab
  • github.com/guzzle/guzzle/pull/3018
  • github.com/guzzle/guzzle/security/advisories/GHSA-cwmx-hcrq-mhc3
  • nvd.nist.gov/vuln/detail/CVE-2022-29248
  • www.drupal.org/sa-core-2022-010

Code Behaviors & Features

Detect and mitigate CVE-2022-29248 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.2.0 before 9.2.20, all versions starting from 9.3.0 before 9.3.14

Fixed versions

  • 9.2.20
  • 9.3.14

Solution

Upgrade to versions 9.2.20, 9.3.14 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-565: Reliance on Cookies without Validation and Integrity Checking

Source file

packagist/drupal/core/CVE-2022-29248.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:10 +0000.