Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2022-25278

CVE-2022-25278: Access bypass in Drupal Core

April 26, 2023 (updated May 9, 2023)

Drupal core form API evaluates form element access incorrectly. This can lead to a user being able to alter data they should not have access to.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2022-25278.yaml
  • github.com/advisories/GHSA-cfh2-7f6h-3m85
  • www.drupal.org/sa-core-2022-013

Code Behaviors & Features

Detect and mitigate CVE-2022-25278 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.0.0 before 9.3.19, all versions starting from 9.4.0 before 9.4.3

Fixed versions

  • 9.3.19
  • 9.4.3

Solution

Upgrade to versions 9.3.19, 9.4.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

packagist/drupal/core/CVE-2022-25278.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:24 +0000.