Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2022-24775

CVE-2022-24775: Improper Input Validation

March 21, 2022 (updated March 29, 2022)

guzzlehttp/psr7 is a PSR-7 HTTP message library used in drupal. Versions prior to 1.8.4 and 2.1.1 is vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values.

References

  • github.com/guzzle/psr7/pull/485/commits/e55afaa3fc138c89adf3b55a8ba20dc60d17f1f1
  • github.com/guzzle/psr7/pull/486/commits/9a96d9db668b485361ed9de7b5bf1e54895df1dc
  • github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
  • nvd.nist.gov/vuln/detail/CVE-2022-24775
  • www.drupal.org/sa-core-2022-006

Code Behaviors & Features

Detect and mitigate CVE-2022-24775 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.0.0 before 9.2.16, all versions starting from 9.3.0 before 9.3.9

Fixed versions

  • 9.2.16
  • 9.3.9

Solution

Upgrade to versions 9.2.16, 9.3.9 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/drupal/core/CVE-2022-24775.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.