Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2020-9281

CVE-2020-9281: Cross-site Scripting

March 7, 2020 (updated December 2, 2021)

A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor allows remote attackers to inject arbitrary web script through a crafted protected comment (with the cke_protected syntax).

References

  • nvd.nist.gov/vuln/detail/CVE-2020-9281

Code Behaviors & Features

Detect and mitigate CVE-2020-9281 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.7.0 before 8.7.12, all versions starting from 8.8.0 before 8.8.4

Fixed versions

  • 8.7.12
  • 8.8.4

Solution

Upgrade to versions 8.7.12, 8.8.4 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/core/CVE-2020-9281.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.