Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2020-13677

CVE-2020-13677: Drupal core access bypass vulnerability

February 12, 2022 (updated October 4, 2023)

Under some circumstances, the Drupal core JSON:API module does not properly restrict access to certain content, which may result in unintended access bypass. Sites that do not have the JSON:API module enabled are not affected.

References

  • github.com/advisories/GHSA-3xr3-phjp-g6p2
  • github.com/drupal/core/commit/7a9bef4b4750d79ab42498e459012cabe4c4bd8b
  • nvd.nist.gov/vuln/detail/CVE-2020-13677
  • www.drupal.org/sa-core-2021-010

Code Behaviors & Features

Detect and mitigate CVE-2020-13677 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.0.0 before 8.9.19, all versions starting from 9.1.0 before 9.1.13, all versions starting from 9.2.0 before 9.2.6

Fixed versions

  • 8.9.19
  • 9.1.13
  • 9.2.6

Solution

Upgrade to versions 8.9.19, 9.1.13, 9.2.6 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Source file

packagist/drupal/core/CVE-2020-13677.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.