Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2019-6340

CVE-2019-6340: Drupal Core Remote Code Execution Vulnerability

May 13, 2022 (updated October 22, 2025)

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2019-6340.yaml
  • github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2019-6340.yaml
  • github.com/advisories/GHSA-3gx6-h57h-rm27
  • github.com/drupal/drupal
  • nvd.nist.gov/vuln/detail/CVE-2019-6340
  • www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-6340
  • www.drupal.org/sa-core-2019-003
  • www.exploit-db.com/exploits/46452
  • www.exploit-db.com/exploits/46459
  • www.exploit-db.com/exploits/46510
  • www.synology.com/security/advisory/Synology_SA_19_09

Code Behaviors & Features

Detect and mitigate CVE-2019-6340 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.0.0 before 7.62.0, all versions starting from 8.0.0 before 8.5.11, all versions starting from 8.6.0 before 8.6.10

Fixed versions

  • 8.6.10
  • 7.62.0
  • 8.5.11

Solution

Upgrade to versions 7.62.0, 8.5.11, 8.6.10 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

packagist/drupal/core/CVE-2019-6340.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.