Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/core
  4. ›
  5. CVE-2018-9861

CVE-2018-9861: Cross-site Scripting

April 19, 2018 (updated July 18, 2019)

Cross-site scripting (XSS) vulnerability in the Enhanced Image plugin for CKEditor.

References

  • nvd.nist.gov/vuln/detail/CVE-2018-9861

Code Behaviors & Features

Detect and mitigate CVE-2018-9861 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.0.0 before 8.4.7, all versions starting from 8.5.0 before 8.5.2

Fixed versions

  • 8.4.7
  • 8.5.2

Solution

Upgrade to versions 8.4.7, 8.5.2 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/core/CVE-2018-9861.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.