Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/config_split
  4. ›
  5. CVE-2025-31688

CVE-2025-31688: Drupal Configuration Split Cross-Site Request Forgery (CSRF) vulnerability

April 1, 2025 (updated April 29, 2025)

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Configuration Split allows Cross Site Request Forgery. This issue affects Configuration Split: from 0.0.0 before 1.10.0, from 2.0.0 before 2.0.2.

References

  • git.drupalcode.org/project/config_split
  • github.com/advisories/GHSA-qq45-cqhg-jwx5
  • nvd.nist.gov/vuln/detail/CVE-2025-31688
  • www.drupal.org/sa-contrib-2025-017

Code Behaviors & Features

Detect and mitigate CVE-2025-31688 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.0, all versions starting from 2.0.0 before 2.0.2

Fixed versions

  • 1.10.0
  • 2.0.2

Solution

Upgrade to versions 1.10.0, 2.0.2 or above.

Impact 6.8 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

packagist/drupal/config_split/CVE-2025-31688.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.