Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/civictheme
  4. ›
  5. CVE-2025-12083

CVE-2025-12083: Drupal CivicTheme Design System allows Cross-Site Scripting (XSS)

October 30, 2025

Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Drupal CivicTheme Design System allows Cross-Site Scripting (XSS). This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.

References

  • github.com/advisories/GHSA-h72q-cq3w-h3wc
  • nvd.nist.gov/vuln/detail/CVE-2025-12083
  • www.drupal.org/sa-contrib-2025-113

Code Behaviors & Features

Detect and mitigate CVE-2025-12083 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.12.0

Fixed versions

  • 1.12.0

Solution

Upgrade to version 1.12.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/drupal/civictheme/CVE-2025-12083.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.