Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/cache_utility
  4. ›
  5. CVE-2025-31690

CVE-2025-31690: Drupal Cache Utility Cross-Site Request Forgery (CSRF) vulnerability

April 1, 2025 (updated April 29, 2025)

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Cache Utility allows Cross Site Request Forgery. This issue affects Cache Utility: from 0.0.0 before 1.2.1.

References

  • git.drupalcode.org/project/cache_utility
  • git.drupalcode.org/project/cache_utility/-/commit/1abf7a438d56ccb11ee3cdac9bdd1707f369ab9e
  • github.com/advisories/GHSA-ccc9-jgj7-hxc7
  • nvd.nist.gov/vuln/detail/CVE-2025-31690
  • www.drupal.org/sa-contrib-2025-019

Code Behaviors & Features

Detect and mitigate CVE-2025-31690 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.2.1

Fixed versions

  • 1.2.1

Solution

Upgrade to version 1.2.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

packagist/drupal/cache_utility/CVE-2025-31690.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.