Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. drupal/ai
  4. ›
  5. CVE-2025-31677

CVE-2025-31677: Drupal AI Cross-Site Request Forgery (CSRF) vulnerability

April 1, 2025 (updated April 29, 2025)

Cross-Site Request Forgery (CSRF) vulnerability in Drupal AI (Artificial Intelligence) allows Cross Site Request Forgery. This issue affects AI (Artificial Intelligence): from 1.0.0 before 1.0.2.

References

  • git.drupalcode.org/project/ai
  • github.com/advisories/GHSA-9w85-x5hg-fr66
  • nvd.nist.gov/vuln/detail/CVE-2025-31677
  • www.drupal.org/sa-contrib-2025-003

Code Behaviors & Features

Detect and mitigate CVE-2025-31677 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0 before 1.0.2

Fixed versions

  • 1.0.2

Solution

Upgrade to version 1.0.2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

packagist/drupal/ai/CVE-2025-31677.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.