Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. dolibarr/dolibarr
  4. ›
  5. CVE-2025-56588

CVE-2025-56588: Dolibarr vulnerable to RCE via the computed field parameter

October 1, 2025

Dolibarr ERP & CRM v21.0.1 were discovered to contain a remote code execution (RCE) vulnerability in the User module configuration via the computed field parameter.

References

  • github.com/Dolibarr/dolibarr
  • github.com/Dolibarr/dolibarr/commit/b03f30c7e27fb89dbfb15902dbf4619ae77f0f86
  • github.com/PhDg1410/Research
  • github.com/advisories/GHSA-27hj-48r9-x2vx
  • nvd.nist.gov/vuln/detail/CVE-2025-56588

Code Behaviors & Features

Detect and mitigate CVE-2025-56588 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 21.0.3

Fixed versions

  • 21.0.3

Solution

Upgrade to version 21.0.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

packagist/dolibarr/dolibarr/CVE-2025-56588.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.