Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. dolibarr/dolibarr
  4. ›
  5. CVE-2019-16685

CVE-2019-16685: Cross-site Scripting

September 27, 2019 (updated October 1, 2019)

Dolibarr has a stored XSS vulnerability via a User Group Description section to card.php. A user with the “Create/modify other users, groups and permissions” privilege can inject script and can also achieve privilege escalation.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-16685

Code Behaviors & Features

Detect and mitigate CVE-2019-16685 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 9.0.5

Fixed versions

  • 10.0.0

Solution

Upgrade to version 10.0.0 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/dolibarr/dolibarr/CVE-2019-16685.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.