Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. dedoc/scramble
  4. ›
  5. CVE-2026-44262

CVE-2026-44262: Scramble vulnerable to remote code execution via evaluation of user-controlled input in validation rules

May 6, 2026 (updated May 13, 2026)

A remote code execution (RCE) vulnerability affects versions 0.13.2 through 0.13.21. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context.

References

  • github.com/advisories/GHSA-4rm2-28vj-fj39
  • github.com/dedoc/scramble/releases/tag/v0.13.22
  • github.com/dedoc/scramble/security/advisories/GHSA-4rm2-28vj-fj39
  • nvd.nist.gov/vuln/detail/CVE-2026-44262

Code Behaviors & Features

Detect and mitigate CVE-2026-44262 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.13.2 before 0.13.22

Fixed versions

  • 0.13.22

Solution

Upgrade to version 0.13.22 or above.

Impact 9.4 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

packagist/dedoc/scramble/CVE-2026-44262.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.