Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. couleurcitron/tarteaucitron-wp
  4. ›
  5. CVE-2024-11718

CVE-2024-11718: tarteaucitron-wp WordPress Plugin Vulnerable to Stored Cross-Site Scripting

May 15, 2025 (updated May 20, 2025)

The tarteaucitron-wp WordPress plugin before 0.3.0 allows author level and above users to add HTML into a post/page, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

References

  • bitbucket.org/ccitron/tarteaucitron-wp
  • github.com/advisories/GHSA-fxpc-qmrh-7j2h
  • nvd.nist.gov/vuln/detail/CVE-2024-11718
  • wpscan.com/vulnerability/02da3a49-20e4-4476-a78d-4c627994a90a

Code Behaviors & Features

Detect and mitigate CVE-2024-11718 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.3.0

Fixed versions

  • 0.3.0

Solution

Upgrade to version 0.3.0 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/couleurcitron/tarteaucitron-wp/CVE-2024-11718.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.