Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. contao/core-bundle
  4. ›
  5. CVE-2025-29790

CVE-2025-29790: Contao Vulnerable to Cross-Site Scripting (XSS) through SVG uploads

March 18, 2025 (updated October 31, 2025)

Users can upload SVG files with malicious code, which is then executed in the back end and/or front end.

References

  • contao.org/en/security-advisories/cross-site-scripting-through-svg-uploads
  • github.com/advisories/GHSA-vqqr-fgmh-f626
  • github.com/contao/contao
  • github.com/contao/contao/security/advisories/GHSA-vqqr-fgmh-f626
  • nvd.nist.gov/vuln/detail/CVE-2025-29790

Code Behaviors & Features

Detect and mitigate CVE-2025-29790 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 before 4.13.54, all versions starting from 5.3.0 before 5.3.30, all versions starting from 5.4.0 before 5.5.6

Fixed versions

  • 4.13.54
  • 5.3.30
  • 5.5.6

Solution

Upgrade to versions 4.13.54, 5.3.30, 5.5.6 or above.

Impact 4.6 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/contao/core-bundle/CVE-2025-29790.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:16 +0000.