Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. codeigniter4/framework
  4. ›
  5. CVE-2022-21715

CVE-2022-21715: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

January 24, 2022 (updated January 28, 2022)

CodeIgniter4 is the branch of CodeIgniter, a PHP full-stack web framework. A cross-site scripting (XSS) vulnerability was found in API\ResponseTrait in Codeigniter4 Attackers can do XSS attacks if a potential victim is using API\ResponseTrait. contains a patch for this vulnerability. There are two potential workarounds available. Users may avoid using API\ResponseTrait or ResourceController Users may also disable Auto Route and use defined routes only.

References

  • codeigniter4.github.io/userguide/incoming/routing.html
  • github.com/codeigniter4/CodeIgniter4/commit/70d881cf5322b7c32e69516aebd2273ac6a1e8dd
  • github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-7528-7jg5-6g62
  • nvd.nist.gov/vuln/detail/CVE-2022-21715

Code Behaviors & Features

Detect and mitigate CVE-2022-21715 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 before 4.1.8

Fixed versions

  • 4.1.8

Solution

Upgrade to version 4.1.8 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/codeigniter4/framework/CVE-2022-21715.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.