Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. codeigniter4/framework
  4. ›
  5. CVE-2017-1000247

CVE-2017-1000247: Improper Input Validation

November 17, 2017 (updated December 4, 2017)

British Columbia Institute of Technology CodeIgniter is vulnerable to HTTP Header Injection in the set_status_header() common function under Apache resulting in HTTP Header Injection flaws.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-1000247
  • www.codeigniter.com/userguide3/changelog.html

Code Behaviors & Features

Detect and mitigate CVE-2017-1000247 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 3.1.3

Fixed versions

  • 4.0.0

Solution

Upgrade to version 4.0.0 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

packagist/codeigniter4/framework/CVE-2017-1000247.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.