Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. code16/sharp
  4. ›
  5. CVE-2025-61457

CVE-2025-61457: code16 Sharp vulnerable to Cross Site Scripting (XSS)

October 21, 2025

code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.

References

  • github.com/advisories/GHSA-9778-v769-qvjf
  • github.com/chimmeee/vulnerability-research/blob/main/CVE-2025-61457
  • github.com/code16/sharp
  • github.com/code16/sharp/blob/6d106b05aa07c6b46f5de28f909b732e1bbcdc47/src/Form/Fields/SharpFormUploadField.php
  • github.com/code16/sharp/commit/bf7fedf2086d86aac16194733a6385564e5cf124
  • github.com/code16/sharp/issues/611
  • github.com/code16/sharp/releases/tag/v9.7.0
  • nvd.nist.gov/vuln/detail/CVE-2025-61457

Code Behaviors & Features

Detect and mitigate CVE-2025-61457 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.7.0

Fixed versions

  • 9.7.0

Solution

Upgrade to version 9.7.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/code16/sharp/CVE-2025-61457.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:21 +0000.