Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. brotkrueml/schema
  4. ›
  5. GMS-2022-2347

GMS-2022-2347: Cross-Site Scripting

June 17, 2022

The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

References

  • github.com/FriendsOfPHP/security-advisories/blob/master/brotkrueml/schema/CVE-2022-33154.yaml
  • github.com/advisories/GHSA-374w-gwqr-fmxg
  • typo3.org/security/advisory/typo3-ext-sa-2022-012

Code Behaviors & Features

Detect and mitigate GMS-2022-2347 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.13.1, all versions starting from 2.0.0 before 2.5.1

Fixed versions

  • 1.13.1
  • 2.5.1

Solution

Upgrade to versions 1.13.1, 2.5.1 or above.

Source file

packagist/brotkrueml/schema/GMS-2022-2347.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.