Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. bottelet/flarepoint
  4. ›
  5. CVE-2022-22110

CVE-2022-22110: Weak Password Requirements

January 8, 2022

In Daybyday CRM, versions 1.1 through 2.2.0 enforce weak password requirements in the user update functionality. A user with privileges to update his password could change it to a weak password, such as those with a length of a single character. This may allow an attacker to brute-force users’ passwords with minimal to no computational effort.

References

  • github.com/Bottelet/DaybydayCRM/commit/a0392f4a4a14e1e3fedaf6817aefce69b6bd661b
  • github.com/advisories/GHSA-96v6-hrwg-p378
  • nvd.nist.gov/vuln/detail/CVE-2022-22110
  • www.whitesourcesoftware.com/vulnerability-database/CVE-2022-22110

Code Behaviors & Features

Detect and mitigate CVE-2022-22110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.1 before 2.2.1

Fixed versions

  • 2.2.1

Solution

Upgrade to version 2.2.1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-521: Weak Password Requirements

Source file

packagist/bottelet/flarepoint/CVE-2022-22110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.