Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. baserproject/basercms
  4. ›
  5. CVE-2022-41994

CVE-2022-41994: baserCMS vulnerable to stored Cross-site Scripting

December 7, 2022 (updated December 12, 2022)

Stored cross-site scripting vulnerability in Permission Settings of baserCMS versions prior to 4.7.2 allows a remote authenticated attacker with an administrative privilege to inject an arbitrary script.

References

  • basercms.net/security/JVN_53682526
  • github.com/advisories/GHSA-vxwf-79ch-f7f7
  • jvn.jp/en/jp/JVN53682526/index.html
  • nvd.nist.gov/vuln/detail/CVE-2022-41994

Code Behaviors & Features

Detect and mitigate CVE-2022-41994 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.7.2

Fixed versions

  • 4.7.2

Solution

Upgrade to version 4.7.2 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/baserproject/basercms/CVE-2022-41994.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:03 +0000.