Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. backpack/crud
  4. ›
  5. CVE-2022-31114

CVE-2022-31114: backpack/crud is vulnerable to Cross-Site Scripting (XSS)

June 3, 2026 (updated June 4, 2026)

It’s a “moderate” vulnerability… but being an admin panel, take this seriously. It’s difficult… but an attacker could conduct a targeted phishing campaign, in order to trick your users or admins to click a malicious link, which under very specific circumstances could give them information… or even admin access. It’s unlikely, but that’s not good enough in admin panels - It should be made impossible. That’s why you are bothered with this.

References

  • backpackforlaravel.com/articles/news/we-recommend-you-fix-this-vulnerability
  • github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-m8xx-3x29-84h8
  • github.com/advisories/GHSA-m8xx-3x29-84h8
  • nvd.nist.gov/vuln/detail/CVE-2022-31114

Code Behaviors & Features

Detect and mitigate CVE-2022-31114 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.63, all versions starting from 4.1.0 before 4.1.69, all versions starting from 5.0.0 before 5.0.13

Fixed versions

  • 4.0.63
  • 4.1.69
  • 5.0.13

Solution

Upgrade to versions 4.0.63, 4.1.69, 5.0.13 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/backpack/crud/CVE-2022-31114.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.