Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. backpack/crud
  4. ›
  5. CVE-2018-20962

CVE-2018-20962: Cross-site Scripting

August 8, 2019 (updated August 15, 2019)

The Backpack component for Laravel allows XSS via the select field type.

References

  • github.com/Laravel-Backpack/CRUD/issues/1297
  • nvd.nist.gov/vuln/detail/CVE-2018-20962

Code Behaviors & Features

Detect and mitigate CVE-2018-20962 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.4.9

Fixed versions

  • 3.4.9

Solution

Upgrade to version 3.4.9 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/backpack/crud/CVE-2018-20962.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.