Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. auth0/wordpress
  4. ›
  5. GHSA-vvg7-8rmq-92g7

GHSA-vvg7-8rmq-92g7: Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency

December 17, 2025

In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.

References

  • github.com/advisories/GHSA-vvg7-8rmq-92g7
  • github.com/auth0/wordpress
  • github.com/auth0/wordpress/commit/b207c6f7fd06507b90c4e6bcc18a857ef9e018de
  • github.com/auth0/wordpress/releases/tag/5.5.0
  • github.com/auth0/wordpress/security/advisories/GHSA-vvg7-8rmq-92g7

Code Behaviors & Features

Detect and mitigate GHSA-vvg7-8rmq-92g7 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.0.0-BETA0 before 5.5.0

Fixed versions

  • 5.5.0

Solution

Upgrade to version 5.5.0 or above.

Impact 6.8 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-1395: Dependency on Vulnerable Third-Party Component
  • CWE-863: Incorrect Authorization

Source file

packagist/auth0/wordpress/GHSA-vvg7-8rmq-92g7.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.