Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. appwrite/server-ce
  4. ›
  5. CVE-2022-25377

CVE-2022-25377: Appwrite Directory Traversal vulnerability

February 23, 2024

The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APP_STORAGE_CERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let’s Encrypt certificates via Appwrite.)

References

  • dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1
  • github.com/advisories/GHSA-wfm3-gq9h-mrjm
  • github.com/appwrite/appwrite
  • github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php
  • github.com/appwrite/appwrite/commit/892f6fa4ba0d44e2435ffad1a84542400cfb7a9b
  • github.com/appwrite/appwrite/pull/2780
  • github.com/appwrite/appwrite/releases/tag/0.12.2
  • nvd.nist.gov/vuln/detail/CVE-2022-25377

Code Behaviors & Features

Detect and mitigate CVE-2022-25377 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.5.0 before 0.12.2

Fixed versions

  • 0.12.2

Solution

Upgrade to version 0.12.2 or above.

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

packagist/appwrite/server-ce/CVE-2022-25377.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.