Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. aimeos/ai-admin-graphql
  4. ›
  5. CVE-2024-47173

CVE-2024-47173: ai-admin-graphql has a Denial of service vulnerability in SaaS and marketplace setups

October 24, 2024

All SaaS and marketplace setups using Aimeos version from 2024.04 up to 2024.07.1 are affected by a potential denial of service attack

References

  • github.com/advisories/GHSA-qxgx-hvg3-v92w
  • github.com/aimeos/ai-admin-graphql
  • github.com/aimeos/ai-admin-graphql/security/advisories/GHSA-qxgx-hvg3-v92w
  • nvd.nist.gov/vuln/detail/CVE-2024-47173

Code Behaviors & Features

Detect and mitigate CVE-2024-47173 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2024.04.1 before 2024.07.2

Fixed versions

  • 2024.07.2

Solution

Upgrade to version 2024.07.2 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H

Learn more about CVSS

Weakness

  • CWE-270: Privilege Context Switching Error

Source file

packagist/aimeos/ai-admin-graphql/CVE-2024-47173.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:27 +0000.