Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. aheinze/cockpit
  4. ›
  5. CVE-2022-2713

CVE-2022-2713: Insufficient Session Expiration

August 9, 2022 (updated August 26, 2022)

Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.

References

  • github.com/advisories/GHSA-vm6p-35rw-3fxc
  • github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b
  • huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290
  • nvd.nist.gov/vuln/detail/CVE-2022-2713

Code Behaviors & Features

Detect and mitigate CVE-2022-2713 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.2.0

Fixed versions

  • 2.2.0

Solution

Upgrade to version 2.2.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

packagist/aheinze/cockpit/CVE-2022-2713.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.