Advisory Database
  • Advisories
  • Dependency Scanning
  1. composer
  2. ›
  3. adodb/adodb-php
  4. ›
  5. CVE-2016-4855

CVE-2016-4855: XSS vulnerability in old test script

May 12, 2017 (updated July 1, 2017)

Cross-site scripting vulnerability in ADOdb allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

References

  • jvn.jp/en/jp/JVN48237713/index.html
  • www.securityfocus.com/bid/92753
  • github.com/ADOdb/ADOdb/issues/274
  • nvd.nist.gov/vuln/detail/CVE-2016-4855

Code Behaviors & Features

Detect and mitigate CVE-2016-4855 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 5.20.5

Fixed versions

  • 5.20.6

Solution

Upgrade to version 5.20.6 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

packagist/adodb/adodb-php/CVE-2016-4855.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.