Advisory Database
  • Advisories
  • Dependency Scanning
  1. cargo
  2. ›
  3. libsqlite3-sys
  4. ›
  5. CVE-2022-35737

CVE-2022-35737: `libsqlite3-sys` via C SQLite improperly validates array index

August 4, 2022 (updated March 27, 2024)

SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.

References

  • blog.trailofbits.com/2022/10/25/sqlite-vulnerability-july-2022-library-api
  • github.com/advisories/GHSA-jw36-hf63-69r9
  • github.com/rusqlite/rusqlite
  • kb.cert.org/vuls/id/720344
  • nvd.nist.gov/vuln/detail/CVE-2022-35737
  • rustsec.org/advisories/RUSTSEC-2022-0090.html
  • security.gentoo.org/glsa/202210-40
  • security.netapp.com/advisory/ntap-20220915-0009
  • sqlite.org/releaselog/3_39_2.html
  • www.sqlite.org/cves.html

Code Behaviors & Features

Detect and mitigate CVE-2022-35737 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.25.1

Fixed versions

  • 0.25.1

Solution

Upgrade to version 0.25.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-129: Improper Validation of Array Index

Source file

cargo/libsqlite3-sys/CVE-2022-35737.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:22 +0000.