Advisory Database
  • Advisories
  • Dependency Scanning
  1. cargo
  2. ›
  3. eza
  4. ›
  5. CVE-2024-25817

CVE-2024-25817: eza Potential Heap Overflow Vulnerability for AArch64

February 8, 2024 (updated March 6, 2024)

In eza, there exists a potential heap overflow vulnerability, first seen when using Ubuntu for Raspberry Pi series system, on ubuntu-raspi kernel, relating to the .git directory.

References

  • github.com/advisories/GHSA-3qx3-6hxr-j2ch
  • github.com/eza-community/eza
  • github.com/eza-community/eza/commit/47c9b90368c49117ba42760bd58acafa3362cbd4
  • github.com/eza-community/eza/security/advisories/GHSA-3qx3-6hxr-j2ch
  • nvd.nist.gov/vuln/detail/CVE-2024-25817

Code Behaviors & Features

Detect and mitigate CVE-2024-25817 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.18.2

Fixed versions

  • 0.18.2

Solution

Upgrade to version 0.18.2 or above.

Impact 8.4 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

cargo/eza/CVE-2024-25817.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.