Advisory Database
  • Advisories
  • Dependency Scanning
  1. cargo
  2. ›
  3. deno
  4. ›
  5. CVE-2024-27936

CVE-2024-27936: Deno's deno_runtime vulnerable to interactive permission prompt spoofing via improper ANSI stripping

March 5, 2024 (updated June 10, 2024)

A maliciously crafted permission request can show the spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents.

References

  • github.com/advisories/GHSA-m4pq-fv2w-6hrw
  • github.com/denoland/deno
  • github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d
  • github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5
  • github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw
  • nvd.nist.gov/vuln/detail/CVE-2024-27936

Code Behaviors & Features

Detect and mitigate CVE-2024-27936 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.32.1 before 1.41.0

Fixed versions

  • 1.41.0

Solution

Upgrade to version 1.41.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-150: Improper Neutralization of Escape, Meta, or Control Sequences

Source file

cargo/deno/CVE-2024-27936.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.